スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

Ubuntu12.04

今まで、Ubuntu11.10を使用していたのだが、
アップデート作業をした後に不具合が発生し、
以前同じことが起こった時にどうしても直らなかった経験上、
いっそのこと、12.04に上げてしまったら解決するのではないか?
と言う安易な考えの元12.04へアップグレードしてみた。

結果・・・・
見事に起動失敗!w

The system is running in low-graphics mode~
と出て正常起動しない。

調べてみたら、
どうやらATIのグラフィックドライバが何やら不具合起こすみたい。
まあ、この後グチャグチャといろいろイジってみたんだけど、
それは置いていて、、、
以下解決までの悪戦苦闘劇


①AMDのドライバをダウンロードしておく。
http://support.amd.com/jp/Pages/AMDSupportHub.aspx
※起動しないんだから、ダウンロード出来ない訳だけど、
 他パーティションにも昔インスコした使ってないUbuntu入っていたので、
 そっから起動して、無事ダウンロード完了。
 12.04をインストールしたパーティションの
 ユーザーディレクトリに入れておいた。
 もし、他パーティションに他のOSとかなかったら、
 UbuntuのCDから起動してDLかな。


②起動失敗したUbuntu12.04を起動。
起動すると、また同じように、”The system is running in low-graphics mode~”なんちゃらと
言ってくるので、そこで "Ctrl+Alt+F1”でコンソールへ。
自分のID、パスワードでログイン。
先程ダウンロードして保存したディレクトリに移動。

③ドライバのインストール
$ chmod +x amd-driver-installer-12-4-x86.x86_64.run #実行権限を与える
$ sudo ./amd-driver-installer-12-4-x86.x86_64.run #sudoしないとダメって怒られた

とりあえず、エラーが出たけどインストールできたっぽい。
再起動してみる。
$ sudo reboot

をを~、無事にログイン画面までたどり着いた。
しかし、ログインしてみると、グラボはウナってるし、エラーが出てるし。。。

④プロプライエタリなドライバをインストール
前に、プロプライエタリなドライバで嫌な思いをしたような気がしてて、
いちいちAMDからDLしたドライバ使ってたんだけど、
11.10で不具合出てたのも、
もしかするとAMDからDLしたドライバが原因かと思い、
ドライバの追加から、プロプライエタリなドライバを有効にしてみた。
 しかし、何度もプロプライエタリって書くのめんどくせw

そして、再起動。

無事にエラーも出ず、綺麗なデスクトップが出てきた!

とりあえず、プロプライエタリなドライバ使ってみるけど、
せっかくAMDからDLしたドライバもあることだし、気が向いたらまたチャレンジしてみる。

以上、めでたしめでたし。
スポンサーサイト

コメントの投稿

非公開コメント

プロフィール

tozionsdoor

Author:tozionsdoor
ただ書くだけ。スクショとか取るの面倒。貼るのも面倒w

検索フォーム
FC2カウンター
最新記事 5件
最新コメント
月別アーカイブ
カテゴリ
リンク
QRコード
QR
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。